PDA

View Full Version : CFMail problem



Doug
September 28th, 2010, 05:47 PM
Hi, I need to send a group of emails out via cfmail by looping over a query. The routine runs fine on my local machine, but when I run it on hostek the emails evidently never go out. I even have a very simple test routine to see what the problem is, but it won't even run on the server.

<cfloop query="qPeople">
<cfoutput> #qPeople.firstName#</cfoutput> is sent <br />
<cfset textmessage = "Name: #qPeople.firstName#"/>
<cfmail from="[email protected]" to="[email protected]" subject="Test">
#textmessage#
</cfmail>
</cfloop>

I get no error messages, the routine runs fine locally CF9.

Where are unsent emails spooled? Is there any way of looking at them?

Doug

AlexY
September 28th, 2010, 06:03 PM
Doug,

Please submit a ticket at http://support.hostek.com or send us an email at [email protected] including your domain name, link to the file that is sending mail and one of the "to" and "from" addresses and we can track it down for you.

JatoDoraEnten
January 27th, 2011, 09:37 AM
I have an app that uses cfmail to do password resets for users. It works fine on our development server, but on the live server, it wont send mail. I have other live apps that send mail though, and the only difference between the working ones and the "broken" one is that the broken one is in an SSL protected folder.

Is there a change I need to make to the cfmail tag to get it to work from an SSL folder, or is this likely some other problem?

WilliamS
January 27th, 2011, 09:54 AM
Sending the mail from an SSL page would not affect the sending of the mail, so it would be some other problem.

Please submit a ticket to http://support.hostek.com with the details of where your cfmail form is located and we will have one of our CF programmers look at it for you.