Not too many people do this, but a customer was trying to publish their site FROM our server TO their local machine and was getting a username/password prompt.

This only happened after they upgraded to IE8.

The solution was to do the following, in IE8:

In IE8 go to Internet Options > Security > Local Intranet > Sites

Then uncheck 'Automatically detect intranet network' and left the next 3 checkboxes alone.